Issue with connecting to database with browser direct

I’m trying to use a neo4j 3.5 database on a network server through the browser direct connection. This was working until I tried it yesterday when suddenly it would not connect. When I go in to the settings, I get an error message saying Failed to construct 'WebSocket': An insecure WebSocket connection may not be initiated from a page loaded over HTTPS. There are no longer the instructions for how to connect to databases that there were previously but I have tried going to the correct IP address for the bolt connector and accepting this but it makes no difference. I can connect fine to a locally run Neo instance using this approach but not one on a remote server. Any idea why this has changed over the last few weeks?

Hi EdWright, is SSL enabled for your server? What browser are you using? Is there a firewall between your machine and your Neo server? What’s host set up for your neo server? When was the last time you were able to connect? The last graphxr server update was on May 8th. Also Chrome seems tightened security lately.

If Neo4j ip is visible from GraphXR server, through the server connection is more reliable. The on-prem installation avoids the SSL issue.


I’ve tried both chrome and firefox but both show the same error message. I don’t think that I have enabled SSL on the server and I haven’t changed the settings between it working and it stopping - is it easy to turn this off in the neo config file? I’m using a VPN to get on to the same network as the server and can access the http version of the neo browser fine and use bolt through the python driver with no problem. I also tried logging on to the server directly and trying to use the browser direct connection from firefox (old version on linux) but still could not connect. The neo server is only visible on our network so we can’t go through the server connect route. Any ideas you have of things to try would be greatly appreciated as the platform worked well initially.